Summary: Library for getting and setting POSIX.1e capabilities.
Name: libcap
Version: 1.0
Release: 1
Copyright: BSD-like or GNU GPL (your choice)
Group: Libraries
Source0: ftp://ftp.kernel.org/pub/linux/libs/security/linux-privs/kernel-2.2/libcap-%{PACKAGE_VERSION}.tar.gz
URL: http://linux.kernel.org/pub/linux/libs/security/linux-privs/

# spec file contributed by Josef Hartmann

%description
This is a library for getting and setting POSIX.1e (formerly POSIX 6)
draft 15 capabilities.

This library would not have been possible without the work of 

 Aleph1, Roland Buresund, Alexander Kjeldaas, Andrew Main and Andrew Morgan.

More information on capabilities in the Linux kernel can be found at

 http://linux.kernel.org/pub/linux/libs/security/linux-privs/


%prep
%setup

%build
make 

%install
make install FAKEROOT=$RPM_BUILD_ROOT

%post
ldconfig

%postun
ldconfig

%clean
rm -rf $RPM_BUILD_ROOT

%files
%doc pgp.keys.asc README License
/usr/man/man2/capget.2
/usr/man/man2/capset.2
/usr/man/man3/_cap_names.3
/usr/man/man3/cap_clear.3
/usr/man/man3/cap_copy_ext.3
/usr/man/man3/cap_copy_int.3
/usr/man/man3/cap_dup.3
/usr/man/man3/cap_free.3
/usr/man/man3/cap_from_text.3
/usr/man/man3/cap_get_flag.3
/usr/man/man3/cap_get_proc.3
/usr/man/man3/cap_init.3
# (not yet supported by the kernel!)
# /usr/man/man3/cap_set_fd.3
# /usr/man/man3/cap_set_file.3
/usr/man/man3/cap_set_flag.3
/usr/man/man3/cap_set_proc.3
/usr/man/man3/cap_size.3
/usr/man/man3/cap_to_text.3
/usr/man/man3/capgetp.3
/usr/man/man3/capsetp.3
/usr/include/sys/capability.h
/sbin/getpcaps
/sbin/setpcaps
/sbin/execcap
/sbin/sucap
/lib/libcap.so
/lib/libcap.so.1
/lib/libcap.so.%{PACKAGE_VERSION}